Tempo aproximado para leitura: 00:01:10 min
Ocorrência
Durante a inicialização do serviço do TOTVS Agro Connector Client, foi apresentada a seguinte mensagem ao tentar iniciar o serviço:
Error 1053: The service did not respond to the start or control request in a timely fashion.
Ambiente
TOTVS Agro - TOTVS Agro - Multicultivo - Administração do Sistema - Todas as Versão
Causa
Durante a tentativa de inicialização, o TOTVS Connector Client realiza automaticamente o download de arquivo .JAR necessários para sua execução. Esse comportamento ocorre mesmo sem a presença explícita da tag <autoRefresh> no arquivo XML do serviço, indicando que o modo de atualização automática está habilitado por padrão.
Por algum motivo — como falha de rede, proxy, timeout ou problemas de permissão — o arquivo .JAR não foi baixado corretamente, o que interrompeu a sequência de inicialização e gerou o erro 1053 do Windows, indicando que o serviço não respondeu em tempo hábil.
Solução
1. Realize o download manual do arquivo .JAR que estava pendentes, utilizando para isso as informações e links que estão dentro do arquivo tc-client-service.xml.
2. Posicionar corretamente no diretório de execução do TOTVS Agro Connector Client o arquivo baixado.
3. Incluir no arquivo tc-client-service.xml a tag (<autoRefresh>false</autoRefresh) para evitar tentativas de atualização automática e apresentação do erro, como forma paliativa para subir o serviço.
0 Comentários