Tempo aproximado para leitura: 00:01:00 min
Ocorrência
Durante a inicialização do serviço do TOTVS Agro Connector Client, foi apresentada a seguinte exceção nos logs de iniciação do serviço:
java.lang.RuntimeException: Can't start redis server. Check logs for details.Essa mensagem indica que o Redis embutido não conseguiu ser iniciado, o que impediu a criação de vários beans do Spring Boot relacionados a monitoramento.
Ambiente
TOTVS Agro - TOTVS Agro - Multicultivo - Administração do Sistema - Todas as Versão
Causa
A causa do erro foi que a porta padrão utilizada pelo Redis geralmente a 6380 já estava ocupada por outro processo no sistema operacional.
Solução
Foi realizada a alteração da porta utilizada pelo Redis para uma porta livre no Sistema, através do arquivo de configuração tc-client-service.xml ou no momento da instalação. Após isso, o Sistema foi inicializado com sucesso.
0 Comentários