Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Agro - PIMS MC - ADM - ERRO: Can't start redis server. Check logs for details.


time.png Tempo aproximado para leitura: 00:01:10 min

Ocorrência
Durante a inicialização do serviço do TOTVS Agro Connector Client, foi apresentada a seguinte exceção nos logs de iniciação do serviço:

java.lang.RuntimeException: Can't start redis server. Check logs for details.

Essa mensagem indica que o Redis embutido não conseguiu ser iniciado, o que impediu a criação de vários beans do Spring Boot relacionados a monitoramento.


Ambiente
TOTVS Agro - TOTVS Agro - Multicultivo - Administração do Sistema - Todas as Versão

Causa
A causa do erro foi que a porta padrão utilizada pelo Redis (geralmente a 6380) já estava ocupada por outro processo no sistema operacional.

Solução
Foi realizada a alteração da porta utilizada pelo Redis para uma porta livre no sistema, através do arquivo de configuração (tc-client-service.xml) ou no momento da instalação. Após isso, o sistema foi inicializado com sucesso.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _