Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - NFE - Erro pdf_load_font Cannot find Font File for Loading

time.png Tempo aproximado para leitura: 00:01:12 min

Ocorrência
Na impressão de documento em PDF pelo programa FT0527 - Emissor DANFE NF-e (versão PDF), FT0528 - Emissor CC-e e FT0921 - Monitor MDFE ocorre a mensagem:
Erro pdf_load font Cannot find font file for loading! stream= SPDF

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Nota Fiscal Eletrônica (NFE) - Todas as Versões

Causa
Quando é gerado o erro: pdf_load_font Cannot find Font File for Loading, um dos motivos é a  imagem de Layout fora do padrão, ou ainda as fontes não instaladas ou não encontradas.


Solução
Para solucionar essa situação é necessário instalar as fontes, pode instalar tanto a DC-CODE128 como a Code2of5, salve na máquina a fonte e com o botão direito faça a instalação para todos os usuários e também adicione no propath "Interfac/bcodefont/" do produto e realize novo teste.

Para confirmar a instalação da fonte, execute o comando abaixo no progress:

MESSAGE "AFM: " SEARCH("interfac/bcodefont/Code2of5.afm") SKIP(2)

"TTG: " SEARCH("c:/windows/fonts/Code2of5.ttf")
VIEW-AS ALERT-BOX INFO BUTTONS OK.

Caso seja apresentado um " ? ", significa que a fonte não foi instalada corretamente.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _