Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - E-mail do Aviso automático não é enviado

time.png Tempo aproximado para leitura: 00:03:30 min

Ocorrência
Ao tentar enviar um aviso automático, o e-mail não é enviado para nenhum destinatário.

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões

Causa 
A falha pode ocorrer devido à configuração incorreta da rotina de envio de e-mails ou à parametrização dos próprios avisos automáticos.

Solução
Para identificar e corrigir a falha, siga os passos abaixo com base nas mensagens exibidas no log de execução da rotina de envio de avisos automáticos:


Incidente: Caso a mensagem apresentada seja: "Buscando registros de avisos para funcionários..." e "Nenhum registro de avisos para funcionários atedende as condições":

Solução: Deve-se acessar o módulo Folha de Pagamento no menu Configurações | Parametrizador | Avisos automáticos onde marcamos a flag “Ativar envio de avisos automáticos”

 

Incidente: Caso a mensagem apresentada seja: "Atualizando registro de aviso..." e "Registro de aviso atualizado: Coligada -- Tipo aviso -- Chapa funcionário sem realizar o envio do e-mail" sem a informação "Enviando e-mail" ou "E-mail enviado".


Solução: O principal teste a ser realizado é verificar se o envio de e-mails está funcionando corretamente tanto para a coligada atual quanto para a coligada global. Outra alternativa é executar a rotina acessando Configurações | Enviar e-mails para Funcionários. Esse procedimento permite identificar possíveis falhas de configuração no sistema que possam estar impedindo o envio de e-mails em qualquer rotina da Folha de Pagamento.

 

 

Após ajustar as configurações, execute novamente a rotina de avisos automáticos. 
Se o envio estiver funcionando corretamente, o log exibirá as mensagens:

  • Enviando e-mail
  • E-mail enviado!
    antes da mensagem "Atualizando registro de aviso..."

Importante

É necessário clicar no botão "Enviar Mensagens" ou acessar a rotina em "Processos | Job que processa todos os avisos automáticos" para que sejam enviados, caso desejar que sua execução seja automática conforme a periodicidade e horário definidos, é obrigatório que o ambiente esteja em N' Camadas.

 

Passo a passo para agendamento dos avisos automáticos

  1. Consulte a documentação Como agendar a execução de um processo para mais detalhes
  2. Verifique se o ambiente está configurado em N' Camadas
  3. Acesse a rotina Processos | Job que processa todos os avisos automáticos
  4. Será apresentada a tela para configurar a execução e poder agendar os avisos automáticos.
  5. Efetue o agendamento conforme necessário

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _