Tempo aproximado para leitura: 00:03:30 min
Ocorrência
Ao acessar o Meu RH e tentar efetuar o login é apresentado a mensagem de erro: Usuário não está autenticado.
Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH - Todas as versões
Causa
Esse incidente ocorre, pois o Meu RH não está conseguindo identificar a base de dados para realizar a conexão.
Solução
O Meu RH verifica qual Base de Dados será acessada por meio dos arquivos RM.Host.exe.config, RM.Host.Service.exe e Web.config. Portanto, é essencial conferir o "ALIAS" especificado nesses arquivos de configuração. Abaixo, seguem os caminhos para a conferência de cada um deles:
Para visualizar a configuração realizada no ambiente, acesse a pasta C:\TOTVS\CorporeRM\RM.Net e localize os arquivos de configuração de seu Host.
Edite o arquivo de configuração do host e verifique qual é o nome do Alias informado na tag DefaultDB
Acesse a agora a pasta C:\TOTVS\CorporeRM\FrameHTML e localize o arquivo Web.config.
Edite o arquivo Web.config e informe o mesmo nome do Alias que está informado na tag DefaultDB do arquivo de host que foi identificado anteriormente.
Observação: O nome do ALIAS informado nos arquivos mencionados deve corresponder exatamente ao registrado no aplicativo RM.AliasManager.exe, localizado na pasta C:\TOTVS\CorporeRM\RM.Net.
Após o procedimento, reinicie todos os serviços RM.Host.Service.exe, RM.Host.Service1.exe, etc de seu ambiente e após iniciados, reinicie também o IIS (poderá utilizar o comando IISRESET pelo CMD em modo administrador)
Após o procedimento, poderá realizar o teste novamente de login.
Importante
Se o erro persistir, acesse a pasta C:\TOTVS\CorporeRM\RM.Net e exclua o arquivo ALIAS.DAT. Em seguida, abra o aplicativo RM.AliasManager.exe na mesma pasta, preencha os dados da base de dados com atenção para não inserir espaços indevidos e salve. O sistema gerará automaticamente um novo arquivo Alias.dat. Por fim, reinicie novamente e teste o acesso ao Meu RH.
0 Comentários