Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATR460 [SQLITE] **** Check / Rebuild SQLITE Tables FAILED

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao executar o MATR460 o sistema retorna o erro [SQLITE] **** Check / Rebuild SQLITE Tables FAILED ***'. in file C:, como corrrigir?

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.

Causa
Este erro ocorre quando a tabela é criada sem o recurso do COLLATE RTRIM quando está com os artefatos mais recentes do Harpia.

Solução
Para solucionar basta, configurar as chaves abaixo na seção [General] no appserver.ini:
 
SQLITE_RebuildTables=0
SQLite_CollateRTRIM=0
SQLite_TrailSpace=1
 
Documentação sobre a comparação de strings no SQLite e sobre cada chave acima:
https://tdn.totvs.com/pages/viewpage.action?pageId=664017473

Após isso tente gerar o MATR460 novamente!

Saiba mais:

Clique aqui e veja mais artigos sobre arquivos e relatórios Legais no Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _