Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - APL - Travamento nos cálculos

time.png Tempo aproximado para leitura: HH:MM:SS min

Ocorrência
Ao efetuar a correção da operação, da aplicação ou empréstimo, ou recálculo de parcelas do empréstimo o programa não termina o processo.

 

 

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Aplicações e Empréstimos (APL) – Versão 12

Causa
Este incidente pode ocorrer quando o programa não consegue editar a planilha vinculada ao produto. Quando isto ocorre geralmente o Excel ou LibreOffice solicita para que seja salva uma cópia da da planilha conforme imagem abaixo. Esta tela pode estar por trás da tela do produto, verifique pelo comando Alt + Tab do Windows:

 


Ao clicar em Salvar o cálculo irá continuar.

Este comportamento ocorre devido as seguintes causas:

1 - A planilha vinculada a operação financeira está aberta em alguma máquina.
2 - O arquivo da planilha vinculada a operação está marcada como Somente Leitura.
3 - O processo do Excel ou LibreOffice está travado na máquina que está ocorrendo o cálculo.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Feche o Excel ou LibreOffice antes de realizar os cálculos. Verifique se outros usuários não estão com a planilha aberta em suas máquinas;

2. Retire a opção Somente Leitura do arquivo no Windows:

 


3. Encerre o processo do Excel ou LibreOffice no Gerenciador de Tarefas do Windows;

Clique com o botão direito na barra de tarefas, acesse o Gerenciador de Tarefas e encerre os processos:

 



Depois de efetuar os procedimentos acima efetue novamente a correção ou recálculo de parcelas.

Caso nenhum dos passos acima surtiu efeito efetue o passo abaixo:

4. Faça uma cópia da planilha e e utilize esta cópia para efetuar o cálculo sem abrir a mesma no Excel ou LibreOffice.

 

 

Efetue a alteração no programa Produto Financeiro -  prgfin/apl/apl005aa.r para utilizar a nova planilha que foi copiada.


Importante
: para saber ou alterar a planilha o sistema está utilizando verifique o artigo: Como parametrizar as planilhas utilizadas no APL

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _