Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Agro - PIMS MC - MNF - Requisição Serviços e Materiais com erro: Column 'CODCOLIGADA, IDMOV, NSEQITMMOV' is constrained to be unique


time.png Tempo aproximado para leitura: 00:00:15min

Ocorrência
No módulo Manutenção de Frotas quando o usuário solicitada dentro de uma ordem de serviços um material ou serviço e o retorno na interação com o REM apresenta a mensagem Column 'CODCOLIGADA, IDMOV, NSEQITMMOV' is constrained to be unique e avaliando o REM a solicitação não é efetivada.

 

 

Ambiente
TOTVS Agro - TOTVS Agro - Multicultivo - Manutenção Frota - Versão 12

Causa
Houve algo na montagem do JSON que que fez com que as informações necessárias para a sua construção, não estejam certas e assim sendo houve o retorno pela API do erro acima comentado.
Avaliar os dados utilizados para construir a mensagem, mas verificar também na tabela RM_MAPPING_ID se o material solicitado tem somente uma TABELA_ORIGEM, pois se houver duas o mesmo esta enviando em duplicidade a requisição ocasionando o erro.

Solução
Para solucionar essa ocorrência é necessário realizar a deleção dos itens duplicados da tabela RM_MAPPING_ID com referência ao material que esta ocorrendo o erro.




Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _