Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Prestadores de Serviços - SIGATEC - Erro "MSRLOCK" ao Incluir Orçamento (TECA400) ou Ordem de Serviço (TECA450) no SIGATEC

time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência
Erro "MSRLOCK" no alias "AA3", ao Incluir Orçamento (TECA400) ou Ordem de Serviço (TECA450) no SIGATEC

Ambiente
Prestadores de Serviços - SIGATEC - TOTVS Gestão Fiscal - Todas as versões.

Causa
Ao tentar incluir um Orçamento (TECA400) ou uma Ordem de Serviço (TECA450) no sistema SIGATEC, está sendo exibida a mensagem de erro "MSRLOCK" no alias AA3.



Solução

1. Verifique os valores dos campos AA3_STATUS e AA3_STAANT.

2. Caso o campo AA3_STATUS seja diferente de '01' ou o campo AA3_STAANT não esteja vazio (diferente de ' '), isso causará o erro "MSRLOCK"

3. Para corrigir o problema, ajuste os campos:

  • AA3_STATUS para '01'
  • AA3_STAANT para vazio (' ')

Observação: Ao criar uma base de atendimento para ser utilizada no Orçamento (TECA400) ou na Ordem de Serviço (TECA450), é fundamental garantir que:

  • AA3_STATUS seja igual a '01'
  • AA3_STAANT esteja vazio (' ')

Essa configuração é crucial para evitar bloqueios e garantir o funcionamento correto das transações.

4. Caso o status da base de atendimento esteja correto, verifique a numeração dos orçamentos AB3_NUMOC e AB6_NUMOS para garantir que estão atualizadas com a próxima sequência disponível na inclusão.

Por exemplo, se o último registro na tabela AB3_NUMOC for "000263", a numeração na inclusão deve ser "000264".

Caso a numeração não esteja correta, acesse o Configurado (SIGACFG) >> Ambiente >> Cadastro >> Controle de Numeração (APCFG110) e ajuste a sequência para o valor correto.

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _