Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - DES - Como Resolver o Erro "Cannot handle text/html content type" ao Consumir API no Fluig

time.png Tempo aproximado para leitura: 00:02:00min

Ocorrência

Ao consumir um método da API através do fluigAPI.getAuthorizeClientService() no Fluig, pode ocorrer o seguinte erro:

com.fluig.authorize.client.exception.ClientOAuth2Exception: Cannot handle text/html content type. Supported content types include JSON, XML and URLEncoded
at com.fluig.authorize.client.ClientOAuth2.execute(ClientOAuth2.java:180)
at com.fluig.authorize


Ambiente
TOTVS Fluig Plataforma - Desenvolvimentos - Todas as versões

Causa
Esse erro ocorre porque a requisição enviada à API não está especificando corretamente o cabeçalho do tipo de conteúdo (‘Content-Type’). Como resultado, a API tenta processar um tipo de conteúdo inválido (‘text/html’).

Solução

Para solucionar esse problema, é necessário configurar o cabeçalho da requisição com o tipo de conteúdo apropriado. O cabeçalho deve incluir a seguinte informação:

headers: {
  Content-Type: 'application/json;charset=UTF-8'
}

Mais informações sobre como configurar corretamente sua requisição e exemplo de desenvolvimento podem ser encontradas na documentação oficial.

 

Importante
Após a inclusão da propriedade os serviços devem ser reiniciados.

A partir da versão Voyager 2.0, as configurações foram migradas dos arquivos domain.xml e host.xml para o standalone.xml. Este artigo se refere às versões anteriores ao Voyager 2.0.
Para mais informações sobre a migração e as diferenças entre as versões, consulte nossa documentação Atualização Voyager (2.0) - O arquivo de configurações da plataforma mudou!

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _