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Ocorrência
Ao executar pedidos via servidor de execução o pedido fica com o campo Motivo Situação com status Tempo de Inatividade Excedido.
Ambiente
Framework - Framework (Linha Datasul) - Básico (BTB) - Versão 12
Causa
Com base na documentação Alterar status do pedido para quando a execução exceda o tempo limite, foi criado o código 36 - Tempo de Inatividade Excedido para ser atribuído aos pedidos que excederem os minutos de cancelamento informados no programa Manutenção de Servidor de Execução - BTB012AA para RPW ou Empresas do Foundation - html.companies para Automação de Tarefas.
No decorrer da execução do pedido, o programa envia ao servidor de execução algumas informações, como por exemplo, qual foi o último objeto utilizado. Caso o servidor de execução não receba essas informações dentro do tempo parametrizado no campo Minutos Cancelamento o status do pedido é alterado para Tempo de inatividade excedido, porém sua execução não é encerrada.
Solução
Recomenda-se alterar o campo Minutos Cancelamento para 90, que é o valor máximo permitido atualmente, em seguida, reiniciar o servidor de execução e realizar a criação de novos pedidos para novo monitoramento.
Se com a alteração acima o erro não for solucionado, será necessário abrir um ticket para a área responsável pelo programa. Se for um programa específico, o programa em questão precisará enviar os acompanhamentos de execução via ut-acomp para que o servidor de execução não altere o status do pedido antes para Tempo de inatividade excedido.
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