Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - BackOffice Linha RM - FIN - Integração RM X Protheus - País de código não encontrado para a classificação 'XX'. Parâmetro de classificação CODCLASSIFICPAIS.


time.png Tempo aproximado para leitura: 00:03:39 min 

Ocorrência

No módulo Gestão Financeira ao tentar cadastrar ou alterar um Cliente/Fornecedor, ocorre um erro durante a integração entre RM e o Protheus.  A seguinte mensagem de erro é exibida: 

País de código não encontrado para a classificação 'XX'. Parâmetro de classificação CODCLASSIFICPAIS

Ambiente
Cross Segmentos - TOTVS BackOffice (Linha RM) - TOTVS Gestão Financeira - A partir da versão 12.1.2306

Causa
Esta mensagem é exibida devido o parâmetro Adapter e Cadastro de País no RM fora do padrão da Integração.

Solução
Para resolver essa ocorrência e eliminar a exibição da mensagem de erro, é imprescindível validar tanto o cadastro do país quanto o parâmetro Adapter CODCLASSIFICPAIS.

Desta forma realize os seguintes passos:

1. No contexto do TOTVS Gestão Financeira, acesse o Menu Cadastros ;

2. Clique na opção Países ;

3. Edite o País Brasil ;

4. Vá em Anexos;

5. Selecione a opção Codificação de País;

6. Edite o item SISCOMEX e informe o código 105 no campo Código País;



7. Acesse o contexto Integração;

8. Clique no Menu EAI 2.0;

9. Clique na opção Parâmetros adapter;

10. Faça o filtro do parâmetro CODCLASSIFICPAIS,

 

Se as tabelas SA1 e SA2 estiverem compartilhadas, elas devem ser cadastradas apenas na coligada 0 e conter apenas um parâmetro.

 

Importante

  • Na Integração com o pacote folha de pagamento a mensagem pode aparecer como RH_CODCLASSIFICPAIS;
  • No cadastro de País BRASIL no RM deve ter mesmo código do Protheus 105. Caso esteja 0105 deverá alterar o código para apenas 105.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _