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Ocorrência
Como resolver o Help A410NSALDO na Devolução de Compra no Pedido de Venda?
Ambiente
Cross Segmentos - BackOffice Protheus - SIGAFAT - Todas as versões;
Causa
O Help verifica se a quantidade informada no campo "Quantidade (C6_QTDVEN)" do pedido de devolução excede a quantidade registrada no campo "Quantidade (D1_QUANT)" da Nota Fiscal de Origem.
Solução
Isso pode ocorrer devido a devoluções anteriores já realizadas, divergências na padronização das casas decimais que geram inconsistências, ou pela falta de cálculo adequado da quantidade restante em casos de devolução parcial. Portanto, existem essas principais soluções:
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Para Devoluções Anteriores:
Verifique no histórico se já houve devoluções para o mesmo item e ajuste a quantidade solicitada.
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Para Divergências em Casas Decimais:
Certifique-se de que as configurações de casas decimais estão padronizadas no sistema.
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Para Devoluções Parciais:
Subtraia manualmente os valores D1_QUANT - D1_QTDEDEV, para saber a quantidade que ainda pode ser devolvida.
Observações
Em casos de Exclusão de Notas Faturadas na Rotina MATA521A:
- Quando uma nota de devolução faturada é excluída pela rotina MATA521A, é fundamental excluir também o pedido correspondente (mesmo que esteja em aberto ou liberado).
- O sistema não atualiza automaticamente o campo D1_QTDEDEV ao excluir apenas pela rotina, causando inconsistências nos valores de devolução.
- Após excluir o pedido, refaça o processo de devolução para corrigir os valores.
Saiba mais
FAT0007 Realizar uma Devolução de Compras
Cross Segmentos - Backoffice Protheus - SIGAFAT - Como fazer uma devolução de compras
Cross Segmentos - Backoffice Protheus - SIGAFAT - Casas decimais no Faturamento
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