Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Agro - PIMS MC - ADM - Atualização/correção de arquivos de migration - AgroDataClient (Conecta Dados Client)

time.png Tempo aproximado para leitura: 00:01:20 min

Ocorrência
Recentemente foi realizada uma atualização/correção em arquivos de Migration (scripts) utilizados pelo AgrodataClient (Conecta Dados Client). Isto se faz necessário para um ajuste na nomenclatura da tabela criada anteriormente de de (jacto_apto_mecanizado_unificada)  para (jacto_apto_mec_unificada) conforme arquivo  V23.00__criacao_tabela_jacto_atividade_mecanizada_unificada.sql.

Ambiente
TOTVS Agro - TOTVS Agro - Multicultivo - Administração do Sistema - ADM - Versão 12

Causa
Atualização/correção em arquivos de Migration (scripts) utilizados pelo AgrodataClient (Conecta Dados Client)

A situação de falha em questão, pode ser vista em log do AgroDataClient .

Solução
Para a correção do erro que é apresentado no log conforme imagem anterior, faz-se necessário seguir as orientações abaixo, de aplicar o script na base do Agro Data Client:

Se a base de dados do cliente for SQL Server (para Agro Data Client):

UPDATE flyway_schema_history
SET checksum = 1277573319
WHERE version = '23.00';

UPDATE flyway_schema_history
SET checksum = -42890495
WHERE version = '30.00';

 

Se a base de dados do cliente for Oracle (para Agro Data Client):

UPDATE "flyway_schema_history" fsh
SET fsh."checksum" = -82297076
WHERE fsh."version" = '23.00';

UPDATE "flyway_schema_history" fsh
SET fsh."checksum" = 1149643796
WHERE fsh."version" = '30.00';


Se a base de dados do cliente for Postgres (para Agro Data Client):

UPDATE flyway_schema_history
SET checksum = -775864564
WHERE version = '23.00';

UPDATE flyway_schema_history
SET checksum = 263649749
WHERE version = '30.00';


Após esta atualização, faça o restart do serviço do Agro Data Client.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _