Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Logix - FRW - Como corrigir erro de profile invalido

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao tentar executar o Logix o mesmo apresenta uma mensagem de erro de profile não existe ou inválido.

Ambiente
Framework - Framework (Linha Logix) - Administração Logix - Todas as versões.

Causa
Após realizar migração de servidor e efetuar a cópia de toda a estrutura do Logix para o novo server, quando executado o mesmo é apresentado o erro abaixo:
Error Profile file does not exist or is invalid in file D:\bamboo/xml-data\build-diriTP11-BUILDV1APPSRV-LGXWIN32Vogxlogixsrv.cpp at line 2136 on LOG GETPROFILEKEYVALUE FUNCOES GENERICAS 4GL/FUNCOES GENERICAS 4GL) 20/06/2024 08:44:36 line: 2388 X



Solução
O erro apresentado indica falha ou falta do arquivo de profile do Logix. (logixprofile.pro ou totvsprofile.pro).

É necessário copiar esse arquivo do antigo servidor para o novo servidor e definir a variável de ambiente FGLPROFILE indicando o local do arquivo. 

Em seguida, reiniciar o serviços do appserver e fazer um novo teste após a alteração da variável.

Saiba mais
Como localizar o arquivo profile

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _