Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Framework RM - BD - Erro "Sua trigger do *** TOTVS Audit *** necessita revisão devido a conversão"

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Erro ao executar algumas rotinas dentro da aplicação RM. 
Sua trigger do *** TOTVS Audit *** necessita revisão devido a conversão, execute o configurador do TOTVS Audit imediatamente! Trigger na tabela XXXXX



Ambiente
Framework - Framework (Linha RM) - Banco de Dados - A partir da 12.1.31

Causa
Este erro ocorre quando houver transações que utilizam a(s) tabela(s) selecionada(s), a Trigger é disparada e grava na tabela de Log (ZAUDITCHANGES) as informações sobre o autor da ação: os dados que foram criados, alterados ou deletados são salvos na "Tabela Espelho" (Ex.: TOTVSAUDIT.PFUNC, tabela espelho a tabela do sistema RM.PFUNC). Desta forma as tabelas que são auditadas e sofrem esse tipo de alteração torna - se necessário fazer a atualização do TOTVS Audit.

Solução

Para solucionar essa ocorrência, realize os seguintes passos:

  1. Acesse o TOTVS Audit através do caminho Módulo Serviços Globais > Aba Administração > Log de Auditoria> Configurações OU Acesse a pasta TOTVS>CorporeRM> RM. Net > Aplicativo: RM.TotvsAudit.exe
  2. Caso o acesso seja dentro da aplicação , clique em Salvar e Configurar:


    Caso o acesso seja através do aplicativo na pasta RM .Net abra o aplicativo e efetue o login.
  3. Faça o Login com o user RM de banco de dados.
  4. Avance até a tela de execução de processos:
    Nesta tela, são exibidos os botões para ativar e inativar e para executar o TOTVSAudit.  Nela são apresentadas as atividades que serão executadas para configuração do TOTVSAudit.

    Com TOTVS Audit Ativo, clique em Executar:




    Após a execução do processo, os itens executados serão exibidos com status de sucesso ou erro, caso ocorra. Quando não há pendências na tabela auditada, a mesma salva as últimas alterações realizadas.

Saiba Mais

Framework - Framework RM - BD - Como converter / atualizar o TotvsAudit

Importante

Para ambientes em CLOUD TOTVS verifique a documentação abaixo:
CLOUD - RM - Habilitar TOTVS Audit via T-Cloud

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _