Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha logix - PED - API de pedido - Regra de cotação inválida

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência

Na integração de pedido por API Rest, está ocorrendo a mensagem:
A regra de cotação é inválida.

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Logix) - Pedidos - Versão 12

Causa
Está passando a informação incorreta para a Regra de Cotação.

Solução
As regras de cotação aceitas são:
P - Padrão - a cotação é normal
F - Fixada
1 - D-1 - cotação do dia anterior
2 - D-2 - cotação de 2 dias atrás
3 - D-3 - cotação de 3 dias atrás
4 - D-4 - cotação de 4 dias atrás
5 - D-5 - cotação de 5 dias atrás

contação.png

A regra default é P - Padrão.
O programa grava essas informações na tabela ped_inf_com_mestre, nos campos regra_cotacao, val_cotacao_fixa, data_vigencia.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _