Tempo aproximado para leitura: 00:01:30 min
Ocorrência
No app Meu RH não aparece a tela de login e é apresentado o erro Sistema indisponível no momento
Ambiente
TOTVS RH - TOTVS RH (Linha Datasul) - Meu RH - Versão 12
Causa
Ao tentar acessar o app Meu RH, o usuário é redirecionado para a tela de "Sistema Indisponível". Este comportamento ocorre devido ao erro 500 retornado pela requisição GET /isRecoverPassword. O erro 500 na requisição isRecoverPassword é causado pela ausência da configuração obrigatória na tabela configur_propried, especificamente a propriedade totvs.enable.recover.password. Essa propriedade é essencial para validar a funcionalidade de recuperação de senha do Sistema.
Solução
Para solucionar o problema, verifique no dump da tabela configur_propried se está ausente o registro referente as propriedades de segurança, por exemplo:
"totvs.enable.recover.password" "true" "totvs.security" "" "" 0 0 0 0 no no ? ? "default"
Se este registro estiver ausente, então no Sistema Datasul, nas Configurações clique na opção Propriedades Do Sistema, acesse a tela Propriedades Segurança e na aba Senha ative ou desative o parâmetro Habilita recuperação de senha, clique no botão Salvar.
Este procedimento é apenas para gerar o registro na tabela, depois poderá desativar ou ativar novamente o parâmetro caso achar necessário.
Em seguida é necessário reiniciar o TOMCAT para que a parametrização seja concluída.
Após reiniciar o serviço, verifique novamente se o registro foi gerado na tabela. Caso positivo, verifique se o acesso ao app Meu RH foi normalizado.
Saiba mais
Para orientações de como gerar o dump de dados - .d - da tabela configur_propried, clique neste link: Framework - Linha Datasul - TEC - Como gerar dump de dados de uma tabela Progress
0 Comentários