Tempo aproximado para leitura: 00:00:50 min
Ocorrência
Ao filtrar os títulos no componente FCRFP186 - Retorno de Título para Cobrança Bancária via API, o sistema apresenta a seguinte mensagem:
Erro ao acionar API de consulta lista de cobranca do Banco do Brasil! Certifique-se de que as configurações do parâmetro por empresa DS_CONFIG_INT_BB estejam corretas. API retornou: {"erros":[{"codigoMensagem":"999","versaoMensagem":"1","codigoRetorno":"N\/A","textoMensagem":"Requisição Inválida (For input string: \"1234-5\")"}]} Adicional : Operação->FCRSVCO181.consultarListaFaturaReq Entidade : FCR_COBRANCASVC Componente : FCRSVCO181
Ambiente
TOTVS Varejo - Moda - Financeiro
Causa
Essa mensagem ocorre, porque o número da conta que vem na requisição da API está diferente da configurada no sistema.
Na mensagem vem a informação (For input string: \"1234-5\"), a meia risca que faz a separação do número da conta com o digito, não pode estar informado no cadastro da conta.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse o componente FCCFM005 - Manutenção de Conta;
2. No campo Cta, informe o número da conta e tecle tab para carregar a configuração;
3. No campo Número conta, remova a meia risca que separa o número da conta com o digito. Ex.: 12345;
4. Clique no botão ou tecle F3 para salvar;
5. Acesse o componente FCRFM022 - Manutenção de Informação da Conta para Cobrança bancária;
6. No campo Cta, informe o número da conta e tecle Tab para carregar os dados bancários;
7. Selecione o checkbox Dv cta. embutido;
8. Clique no botão ou tecle F3 para salvar;
9. Com essa configuração ao filtrar o título a mensagem não ocorrerá.
0 Comentários