Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Agro - PIMS MC - AER - Erro Insumos não captados na Captação de Custos

time.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência
No módulo Multicultivo – Atividades e Recursos - AER, ao realizar a captação de custos quando a origem dos custos é relacionada aos apontamentos de mobilidade, quando não há um fator de conversão cadastrado para o insumo, o Sistema está gravando valor zero no campo (QT_CONS_CONV). Como resultado, esses apontamentos não estão sendo captados corretamente. No entanto, não é gerado nenhum log de erro ou de ocorrência durante o processamento do custo, o que dificulta a identificação e correção do problema.

Ambiente
TOTVS Agro - TOTVS Agro – Multicultivo – Atividades e Recursos - AER – Todas as versões

Causa
Esse incidente ocorre pois os insumos não tem fator de conversão cadastrado.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Verifique se na tabela AU_APTO_INS_LC_DE coluna QT_CONS_CONV se tem valor zero, caso haja valor zero deverá ser executado o comando de update para gravar o valor NULL;

**Executar a Instrução: **


**** Caso oracle:**


UPDATE AU_APTO_INS_LC_DE SET QT_CONS_CONV = NULL WHERE
QT_CONS_CONV = 0;

 

COMMIT;


**** Caso SQLServer**


BEGIN TRANSACTION


UPDATE AU_APTO_INS_LC_DE SET QT_CONS_CONV = NULL WHERE
QT_CONS_CONV = 0;


COMMIT;

2.
Verifique no Portal de Mobilidade o serviço Importar Atividade Agrícola – Insumos por locais – DE se existe na query o comando  CASE WHEN *qtConsConv > 0 THEN *qtConsConv END, caso não esteja, deverá ser incluído para que os novos boletins a serem importados grave com o valor correto, nesse caso NULL, isso para insumos que não tem o fator de conversão;

3. Realize a captação de custos e o processamento.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _