Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - CON - Como autorizar o CORS para chamadas externas

relogio_tempo_leitura_2.png Tempo aproximado para leitura: 00:02:00 min

 

Ocorrência
Está ocorrendo o erro de CORS para acessar uma API externa. Como solucionar?

Access to XMLHttpRequest at (...) from origin 'null' has been blocked by CORS policy


Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - Todas as versões

Causa
Pode ocorrer erro nas chamadas de API e webservice nos casos em que utilizam outra origem diferente da URL de acesso, por exemplo: estou acessando fluig.com e existe uma API chamando totvs.com.br, então ocorre esse erro no navegador. 

Solução
Se for essa a causa, é necessário alterar as configurações do servidor que faz o proxy reverso para autorizar essa URL. Para verificar o procedimento, consulte nossa documentação sobre CORS (Cross-origin Resource Sharing).
Você pode ainda montar um script JavaScript para fazer essa autenticação de chamadas externas (é necessário devido à restrição de segurança dos navegadores). Também existem serviços terceiros com APIs que facilitam essa autorização via OAuth.

Saiba Mais
Um maior detalhamento sobre essa configuração e exemplos de requisição podem ser encontrados na documentação disponibilizada pelo MozillaCross-Origin Resource Sharing (CORS)

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _