Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

FL - FORM - Por que datas em registros de formulários estão perdendo formatação em formatos distintos na base de dados

Ocorrência
Ao salvar registros de formulários que contenham datas, ou movimentar solicitações com formulários que contenham datas, em algumas situações as datas estão sendo salvas nas metalistas/registros de formulário (tabela única) com padrões diferentes.

Ambiente
fluig Studio - Formulário - Todas as versões.

Causa
Isso ocorre quando o navegador utilizado pelos usuários diverge entre Chrome e Firefox/IE. No Chrome, toda e qualquer data é persistida com o padrão americano (yyyy-mm-dd) caso seja utilizado o campo do tipo "date". No caso do Firefox/IE, campos do tipo "date" são substituídos por campos do tipo "text" e então é adicionado a função datePicker do jQuery para os mesmos, sendo assim o campo fica com o padrão brasileiro e é persistido como tal.

Solução
Caso seja utilizada a versão 1.4.12 ou superior do sistema e o formulário fora criado pelo sistema (através do gerenciamento de processos), basta salvar o formulário novamente (editar e salvar) pra que o formulário inclua o evento inputFields com a formatação de data por padrão. Caso seja um formulário próprio do cliente, pode-se utilizar o evento de formulário inputFields conforme exemplificado no link a seguir: Exemplo de uso de inputFields:

function inputFields(form) {
    if (form.getValue("NOME_DO_CAMPO_DATA").match("^[0-3]?[0-9]/[0-3]?[0-9]/(?:[0-9]{2})?[0-9]{2}$")) {
        var split = form.getValue("NOME_DO_CAMPO_DATA").split('/');
        form.setValue("NOME_DO_CAMPO_DATA", split[2] + '-' + split[1] + '-' + split[0]);
    }
}

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _