Tempo aproximado para leitura: 00:04:11 min
Ocorrência
Ao executar uma indexação ou busca é exibida a mensagem Serviço indisponível: O serviço de busca está indisponível. Consulte o administrador do sistema.
Em log é apresentada a seguinte mensagem:
Failed to create Solr core:1
O que pode estar causando esse erro, e como resolvê-lo?
Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - A partir da versão 1.6.0
Causa
Esse erro acontece porque o endereço de acesso ao Solr não está configurado corretamente. Na tela de Parâmetros da Plataforma o campo URL de acesso ao Solr está preenchido com o endereço IP do servidor do Solr, por exemplo 192.168.0.100. Porém, é indicado o preenchimento deste campo com o localhost.
Correto: http://localhost:8983/solr
Errado: http://192.168.0.100:8983/solr
Solução
Recomendamos o preenchimento do campo URL de acesso ao Solr com o localhost ao invés do IP. Para isso, siga os passos abaixo:
1. Acesse a plataforma com o usuário wcmadmin e navegue até o Painel de Controle → WCM → Configurações do Sistema → aba Parâmetros da Plataforma.
2. Ao lado do campo URL de acesso ao Solr existe um ícone de informação adicional. Ao passar o cursor do mouse sobre ele esse ícone é exibida a mensagem "URL de acesso ao Solr, http://HOST:PORTA/CONTEXTO". Preencher o campo com o localhost, por exemplo: http://localhost:8983/sorl.
3. Faça os ajustes, salve e reinicie os serviços do fluig.
4. Após a reinicialização, recomendamos a reindexação completa da plataforma, para atualizar o serviço de busca.
Atenção! Se o ambiente estiver em cluster, a configuração deve ser HOST:PORTA. A porta utilizada será a do serviço de coordenação do cluster, que por padrão é a porta do http + 1000, por exemplo: 192.168.0.100:9080. Para saber mais sobre configuração do Solr em cluster acesse Fluig Indexer em alta disponibilidade.
0 Comentários