Ocorrência
Durante a instalação/atualização da plataforma, as seguintes mensagens de erro são apresentadas:
- O serviço Fluig está em execução. Finalize o serviço para continuar a atualização.
- Existe algum arquivo aberto ou em uso. Feche todas as aplicações que possam estar usando arquivos.
- O serviço do Solr está em execução. Finalize o serviço para continuar a atualização.
- The system cannot find the path specified.
- Mensagens em branco.
- Unable to evaluate expression using this context.
- [...]\dataset.author.csv (O dispositivo não está pronto).
Abaixo alguns exemplos das mensagens que podem ocorrer:
O que pode estar ocorrendo? Como resolver?
Ambiente
TOTVS Fluig Plataforma - Instalação - A partir da versão 1.6.0 - Servidor Windows
Causa
O instalador da plataforma verifica se todos os serviços e arquivos da plataforma estão abertos ou em uso durante a atualização/instalação para garantir que a mesma seja feita com segurança.
Ao ignorar os erros e prosseguir com a instalação, é possível finalizá-la. Porém, ao tentar inicializar a plataforma, os serviços são encerrados logo em seguida.
Solução
Certifique-se de ter fechado todos os arquivos e finalizado os serviços do Fluig:
- fluig
- fluig_Indexer
- fluig_RealTime
Faça um teste tentando renomear a pasta de instalação da plataforma. Se o sistema operacional não permitir que a pasta seja renomeada, significa que algum arquivo está aberto ou em execução.
Se isso acontecer, siga os passos abaixo para executar a atualização/instalação:
1. Acesse a tela de Serviços do Windows. Procure pelos serviços fluig, fluig_Indexer e fluig_RealTime.
2. Acesse as propriedades de um dos serviços.
3. Altere o Tipo de Inicialização de Automático para Manual.
Essa configuração será utilizada apenas para reiniciar o servidor e fazer a atualização. Depois o serviço poderá ser configurado novamente para inicialização automática.
Esse passo é importante para evitar que o serviço inicialize e seja preciso parar o serviço manualmente antes de executar a atualização.
4. Acesse a pasta [diretório_instalação]\appserver\domain e exclua as pastas temporárias: data, log, servers e tmp.
5. Reinicie o servidor; Faça a atualização da plataforma; Siga os passos 1, 2 e 3 novamente para alterar o Tipo de Inicialização para Automático; Execute todos os serviços novamente.
6. Verifique se há alguma aplicação de backup rodando ou algum antivírus em execução. Se tiver, desative e tente executar a instalação novamente.
7. Verifique se o usuário que está executando o instalador possui permissão de administrador e tente executar o instalador, conforme o seguinte artigo: Como iniciar o instalador/atualizador com usuário administrador no Windows.
Importante
O arquivo install.log pode auxiliar a identificar o que pode estar impedindo a instalação/atualização. Verifique esse arquivo, que se encontra no diretório de instalação da plataforma, e se precisar de apoio para analisá-lo, envie-o para o Suporte TOTVS Fluig.
A partir da versão Voyager 2.0, as configurações foram migradas dos arquivos domain.xml e host.xml para o standalone.xml. Este artigo se refere às versões anteriores ao Voyager 2.0.
Para mais informações sobre a migração e as diferenças entre as versões, consulte nossa documentação Atualização Voyager (2.0) - O arquivo de configurações da plataforma mudou!
Saiba Mais
Para mais informações, acesse Guia de atualização da plataforma.
0 Comentários