Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - CON - Caracteres especiais impedindo a inicialização do servidor de aplicação

Ocorrência
O servidor de aplicação Wildfly (a partir da atualização 1.6) ou JBoss (atualização 1.5) não está iniciando. O que pode estar causando isso e como resolver?

Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - A partir da versão 1.5

Causa
No arquivo [diretório_instalação]/appserver/domain/configuration/domain.xml para atualização 1.6, 1.7 e 1.8 ou [diretório de instalação do Fluig]/appserver/standalone/configuration/standalone.xml para atualização 1.5 e 2.0.

Alguns valores são protegidos e ficam reservados pela linguagem Xml, como por exemplo: @, #, $, %. Estes caracteres geralmente são atribuidos a campos de senhasem campos de senha, que podem ser localizados pela palavra password.


Solução
Para solucionar esse problema, no arquivo de configuração localiza a tag <password> e ajuste os valores conforme descrito abaixo:

<password>$fluig&2@+15</password>

Deve ficar assim:

<password><![CDATA[$fluig&2@+15]]></password>

Atenção
Para senhas em campos dentro de tags, como <login password="&stasenha" />, não é possível usar a tag CDATA. Para estes casos, os caracteres especiais devem ser substituídos conforme tabela abaixo:

Caracter Código

&amp;
<

&lt;

&gt;

&apos;

&quot;

 

Nota
A partir da versão Voyager 2.0, as configurações foram migradas dos arquivos domain.xml e host.xml para o standalone.xml. Este artigo se refere às versões anteriores ao Voyager 2.0.

 

Para versões Voyager 2.0 o diretório está localizado em: [diretório de instalação do Fluig]/appserver/standalone.

 

Para mais informações sobre a migração e as diferenças entre as versões, consulte nossa documentação Atualização Voyager (2.0) - O arquivo de configurações da plataforma mudou!

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _