Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - CON - Como iniciar os serviços no Red Hat Cent OS 7 quando ocorre falha nas instalações

Ocorrência
Não foram criados os serviços durante a instalação via modo caractere no sistema operacional Cent OS 7. Como faço para iniciar os serviços quando ocorre falha nas instalações?

Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - Linux | Cent OS 7 - Todas as versões

Causa
A Red Hat alterou o caminho utilizado para registrar os serviços.

Solução
Escolha uma das versões da plataforma e realize os passos abaixo:

  • A partir da atualização 1.6

1. É possível iniciar os serviços utilizando o seguinte comando:

sh <ARQUIVO_SH_FLUIG> -b 0.0.0.0 > /dev/null 2>&1 &

2. Para iniciar o Fluig, utilize:

sh <DIRETÓRIO_INSTALAÇÃO>/appserver/bin/domain.sh -b 0.0.0.0 > /dev/null 2>&1 &

3. Para iniciar o RealTime, utilize:

sh <DIRETÓRIO_INSTALAÇÃO>/node/bin/node ws_server.js > /dev/null 2>&1 &

4. Para iniciar o Sorl (servidor de indexação), utilize:

service fluig_Indexer start

Observações

Para verificar se os serviços estão no ar é possível utilizar o comando telnet.

1. Para o Fluig utilize:

telnet <IP_DA_MAQUINA> <PORTA_INSTALAÇÃO>

2. Para o RealTime, utilize:

telnet <IP_DA_MAQUINA> 7777

3. Para o MenCached, utilize:

telnet 127.0.0.1 11211

4. A resposta do comando telnet será igual ao exemplo abaixo (modelo utilizando o teste do Solr).

$ telnet 127.0.0.1 8983
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.

 

  • Atualização 1.5.13 e anteriores

1. É possível iniciar os serviços utilizando o seguinte comando:

sh <ARQUIVO_SH_FLUIG> -b 0.0.0.0 > /dev/null 2>&1 &

2. Para iniciar o Fluig, utilize:

sh <DIRETÓRIO_INSTALAÇÃO>/jboss/bin/standalone.sh -b 0.0.0.0 > /dev/null 2>&1 &

3. Para iniciar o RealTime, utilize:

sh <DIRETÓRIO_INSTALAÇÃO>/node/bin/node ws_server.js > /dev/null 2>&1 &

4. Para instalar o MenCached, utilize:

sh <DIRETÓRIO_INSTALAÇÃO>/memcachedSetup.sh

5. Para iniciar o MenCached, utilize:

service memcached start

Observações

Para verificar se os serviços então no ar é possível utilizar o comando telnet. 

1. Para o Fluig, utilize:

telnet <IP_DA_MAQUINA> <PORTA_INSTALAÇÃO>

2. Para o RealTime, utilize:

telnet <IP_DA_MAQUINA> 7777

3. Para o MenCached, utilize:

telnet 127.0.0.1 11211

4. A resposta do comando telnet será igual ao exemplo abaixo (modelo utilizando o teste do MenCache).

$ telnet 127.0.0.1 11211
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.


Importante
A partir da versão Voyager 2.0, as configurações foram migradas dos arquivos domain.xml e host.xml para o standalone.xml. Este artigo se refere às versões anteriores ao Voyager 2.0.
Para mais informações sobre a migração e as diferenças entre as versões, consulte nossa documentação Atualização Voyager (2.0) - O arquivo de configurações da plataforma mudou!

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _