Tempo aproximado para leitura: 00:02:00 min
Ocorrência
Ao acessar a plataforma, após algum tempo tentando se conectar com o RealTime, é apresentada a mensagem de timeout no console do navegador?
Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - Todas as versões.
Causa
Em alguns casos, apesar do RealTime estar configurado com o endereço correto do servidor, a plataforma está sendo acessada através de outra URL e por conta disso, o navegador bloqueia as requisições por causa das politicas CORS.
Outra causa comum, é que a plataforma está sendo acessada pela internet externamente à rede em que está instalado, e a porta do RealTime não está sendo redirecionada externamente.
Solução
Na configuração do RealTime, utilizar o mesmo endereço utilizado para acessar a plataforma (IP, DNS ou hostname), alterando somente a porta e garantindo que o serviço esteja disponível na porta configurada.
0 Comentários