Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - CON - Plataforma lenta para iniciar ou com erros na criação de empresa

Ocorrência
A plataforma está demorando para iniciar ou está gerando erros ao criar novas empresas.

Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - Versão 1.6.5 (Liquid) ou superiores.

Causa
Na atualização 1.6.5 foram realizadas alterações na arquitetura da plataforma que geraram um aumento no consumo da memória padrão do instalador, mas ambientes instalados antes da versão 1.6.5 estão parametrizados incorretamente. 

Solução
No final do arquivo host.xml na seção {code}servers{}, altere os parâmetro do bloco fluig1 aumentando o max-size para 4g e o size para 2g, e.g.:

<server auto-start="true" group="fluig" name="fluig1">
<jvm name="default">
<heap max-size="${env.FLUIG_MEMORY_MAX:2000m}" size="${env.FLUIG_MEMORY_MIN:1500m}"/>
<jvm-options>
<option value="-Dfile.encoding=utf8"/>
<option value="-XX:MaxMetaspaceSize=1024m"/>
<option value="-Djavamelody.disabled=true"/>
<option value="-Xdebug"/>
<option value="-Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=n"/>
</jvm-options>
</jvm>
</server>

Deve ficar como no exemplo abaixo:

<server auto-start="true" group="fluig" name="fluig1">
<jvm name="default">
<heap max-size="${env.FLUIG_MEMORY_MAX:4g}" size="${env.FLUIG_MEMORY_MIN:2g}"/>
<jvm-options>
<option value="-Dfile.encoding=utf8"/>
<option value="-XX:MaxMetaspaceSize=1024m"/>
<option value="-Djavamelody.disabled=true"/>
<option value="-Xdebug"/>
<option value="-Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=n"/>
</jvm-options>
</jvm>
</server>

Saiba Mais

Nota
A partir da versão Voyager 2.0, as configurações foram migradas dos arquivos domain.xml e host.xml para o standalone.xml. Este artigo se refere às versões anteriores ao Voyager 2.0.

 

Para versões Voyager 2.0 o diretório está localizado em: [diretório de instalação do Fluig]\appserver\standalone.

 

Para mais informações sobre a migração e as diferenças entre as versões, consulte nossa documentação Atualização Voyager (2.0) - O arquivo de configurações da plataforma mudou!

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _