Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - CON - Como desabilitar a geração de log secundário

Ocorrência
Identificamos um tamanho incomum no arquivo de log fluig-stdout, localizado no caminho [diretório_instalação]/appserver/domain/log. Esse log só é recriado ao reiniciar os serviços do Fluig.

Qual o motivo da existência deste log secundário e existe alguma forma de configuração para desabilitar este log?


Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - Todas as versões


Causa
Esse arquivo de log fluig.stdout é gerado pela plataforma quando ocorre a inicialização pelo arquivo domain.bat (localizado em [diretório_instalação]\appserver\domain\bin), mas também armazena os logs normalmente em [diretório_instalação]\appserver\domain\servers\fluig1\log

Quando fizer a inicialização dos serviços pela tela de Serviços do Windows, a plataforma gera os logs dentro de [diretório_instalação]\appserver\domain\servers\fluig1\log, mas ainda assim registra o log no arquivo fluig.stdout.

Então é possível desabilitar esse log secundário, já que ele existe no outro caminho citado acima.


Solução

Para desabilitar o log siga os passos a seguir:

1. Pare os serviços do Fluig;

2. Edite o arquivo [diretório_instalação]\appserver\bin\service\service.bat em um editor de texto. Armazene um backup deste arquivo em outro diretório, não dentro da instalação da plataforma;

3. Procure pelos parâmetros --StdOutput=auto e --StdError=auto e remova-os;

4. Apague os arquivos temporários data, log, servers e tmp na pasta [diretório_instalação]\appserver\domain.

5. Remova e crie o serviço Fluig. Para saber mais acesse: Recriar serviços do Fluig;

6. Inicie os serviços do Fluig. 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _