Ocorrência
Identificamos um tamanho incomum no arquivo de log fluig-stdout, localizado no caminho [diretório_instalação]/appserver/domain/log. Esse log só é recriado ao reiniciar os serviços do Fluig.
Qual o motivo da existência deste log secundário e existe alguma forma de configuração para desabilitar este log?
Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - Todas as versões
Causa
Esse arquivo de log fluig.stdout é gerado pela plataforma quando ocorre a inicialização pelo arquivo domain.bat (localizado em [diretório_instalação]\appserver\domain\bin), mas também armazena os logs normalmente em [diretório_instalação]\appserver\domain\servers\fluig1\log.
Quando fizer a inicialização dos serviços pela tela de Serviços do Windows, a plataforma gera os logs dentro de [diretório_instalação]\appserver\domain\servers\fluig1\log, mas ainda assim registra o log no arquivo fluig.stdout.
Então é possível desabilitar esse log secundário, já que ele existe no outro caminho citado acima.
Solução
Para desabilitar o log siga os passos a seguir:
1. Pare os serviços do Fluig;
2. Edite o arquivo [diretório_instalação]\appserver\bin\service\service.bat em um editor de texto. Armazene um backup deste arquivo em outro diretório, não dentro da instalação da plataforma;
3. Procure pelos parâmetros --StdOutput=auto e --StdError=auto e remova-os;
4. Apague os arquivos temporários data, log, servers e tmp na pasta [diretório_instalação]\appserver\domain.
5. Remova e crie o serviço Fluig. Para saber mais acesse: Recriar serviços do Fluig;
6. Inicie os serviços do Fluig.
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