Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - CON - Erro de conexão ORA-12505 na inicialização da plataforma

Ocorrência
Instalei a plataforma conectando em um banco de dados Oracle porém a plataforma não sobe. No arquivo server.log aparece o erro abaixo: 

ORA-12505, TNS:listener does not currently know of SID given in connect descriptor

Como soluciono este problema?

Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - Todas as versões | Banco de dados: Oracle

Causa
Em um dos arquivos de configuração do servidor de aplicação, nas tags connection-url o valor informado está diferente do configurado no arquivo de configuração do Oracle tnsnames.ora, assim o banco de dados não está conseguindo encontrar a base solicitada.

Solução
Alterar as tags de conexão (connection-url) no arquivo domain.xml localizado em [diretório_instalação]\appserver\domain\configuration, conforme exemplo abaixo. Importante mencionar que existem duas tags de conexão com o banco, portanto as duas devem ser alteradas. As informações de conexão do arquivo tsnames.ora e as tags do domain.xml devem estar iguais.

<connection-url>jdbc:oracle:thin:@[host servidor]:[porta]:[nome do serviço]</connection-url>

Modelo de arquivo tsnames.ora. Localize em sua instalação do Oracle este arquivo, para validar as informações de conexão.

NOME_CONEXAO =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = [host servidor])(PORT = [porta]))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = [nome do serviço])
)
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _