Ocorrência
Notamos que uma ação na plataforma não está sendo executada, apresentando a mensagem de erro: Could not open connection. Como posso resolver esta situação?
javax.persistence.PersistenceException: org.hibernate.exception.GenericJDBCException: Could not open connection
Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - A partir da versão 1.6.0
Causa
O pool de conexões não está suportando a carga, seja por processos (threads) que não estão liberando ou fechando as conexões, seja pela quantidade de usuários utilizando o sistema simultaneamente.
Solução
Nesse caso, existem duas verificações que podem ser feitas.
01. Verifique o desenvolvimento de widgets sobre a plataforma, a fim de encontrar processos (threads) que não estejam liberando conexões ao java:/jdbc/FluigDS. Esta situação pode ajudar no estouro do pool de conexões.
02. Considere aumentar o pool de conexões. Para isso, siga os passos abaixo:
- Pare os serviços do fluig;
- Altere o parâmetro max-pool-size no arquivo domain.xml, localizado em [diretório_instalação]/appserver/domain/configuration, informando um valor maior que o atual. Isso fará com que o número de conexões aumente e isso deve solucionar ou, ao menos, diminuir o problema;
- Salve a alteração, reinicie os serviços e faça um novo teste.
Atenção: Um número muito alto de conexões ao banco de dados gera gasto no gerenciamento do pool e o aumenta o consumo de banco.
Saiba Mais
Confira mais informações na documentação Avaliação de lentidão na plataforma.
0 Comentários