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Fluig - Plataforma - ECM - Mensagem: "O documento não foi encontrado" ao visualizar documento

Ocorrência
Ao tentar visualizar um documento DOCX o sistema demora algum tempo e depois apresenta a mensagem: O documento não foi encontrado.
Por que isso ocorre? Como resolver?

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Ambiente
TOTVS Fluig Plataforma - Documentos - Todas as versões

Causa
O problema é causado por uma limitação no MS Office 2016. Analisamos o arquivo DOCX e descobrimos que ele contém imagens no formato EMF. Há algo sobre essas imagens EMF específicas que fazem com que o MS Word falhe ao exportar o conteúdo para PDF. 

O aplicativo de interface do usuário do MS Word mostra o mesmo problema: A exportação falhou devido a erro inesperado. 

Solução
Descobrimos uma maneira de contornar esse problema do MS Office alterando ligeiramente o valor de brilho em todas as imagens do documento, seguindo os passos abaixo:

1. Abrir o arquivo DOCX no MS Word;

2. Ajustar ligeiramente o brilho (por exemplo, mais ou mais 1%) em todas as imagens do documento;

inline-9819429.png

3. Salvar o arquivo.

Pronto! Após estes passos, deve ser possível visualizar o documento normalmente.

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