Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - BPM - Como comparar variáveis de tipos "string" e "number" em eventos com maior e menor

Ocorrência
Constantemente há a necessidade de realizar a comparação entre variáveis, ou com valores fixos, principalmente nas condições de atividades automáticas.

Ambiente
fluig - Processos - Todas as versões.

Causa
O JavaScript só reconhece como number valores com um único ponto de até 21 casas decimais, ou seja, valores de string com milhares como 1.000.02 não serão considerados number e falharão em todas as comparações com uma variável de tal tipo.

Solução
Modificar a variável de comparação para se adequar ao formato necessário.
Abaixo, seguem exemplos de validações que podem ser utilizadas como condições para atividades automáticas:

Comparar um campos do formulário com um valor fixo

var i = parseFloat(hAPI.getCardValue("[NOME_DO_CAMPO]").replace("." , "").replace("," , ".").trim());
log.info('********** valor do campo um = ' + i);
var j = parseFloat(5000.00);
log.info('********** valor fixo = ' + j);
i >= j;

Comparar dois campos do formulário

var i = parseFloat(hAPI.getCardValue("[NOME_DO_CAMPO_UM]").replace("." , "").replace("," , ".").trim());
log.info('********** valor do campo um = ' + i);
var j = parseFloat(hAPI.getCardValue("[NOME_DO_CAMPO_DOIS]").replace("." , "").replace("," , ".").trim());
log.info('********** valor do campo dois = ' + j);
i >= j;

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _