Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - CON - Como configurar o Oracle via OCI

Ocorrência
Por que a conexão via OCI com o banco de dados Oracle não funciona?

Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - A partir da versão 1.6.0 | Banco de Dados: Oracle

Causa
A configuração feita pelo instalador é do tipo THIN.

Solução
É necessário alterar a configuração de acesso ao banco de dados no arquivo domain.xml (localizado em [Instalação fluig]\appserver\domain\configuration) conforme exemplo abaixo:

  • No bloco datasources, em pool-name="FluigDS" e pool-name="FluigDSRO" altere a tag connection-url para <connection-url>jdbc:oracle:oci8:@nome_banco</connection-url>

  • Caso exista um bloco com pool-name="AppDS", efetue também a alteração dessa tag connection-url.

  • No bloco drivers, altere a tag driver para <driver name="oracleDriver" module="com.oracle.oci"> e a tag driver-class para <driver-class>oracle.jdbc.OracleDriver</driver-class>

Além disso, é necessário efetuar os passos abaixo:

1. Criar a pasta main no seguinte diretório [Instalação fluig]/appserver/modules/com/oracle/oci, para isto utilize como modelo a pasta main localizado em [Instalação fluig]/appserver/modules/com/oracle/jdbc;

2. Procurar o arquivo de drive jdbc do client instalado, vai estar em $Oracle_home/jdbc/lib, o nome é semelhante a ojdbc6_g.jar;

3. Copiar este arquivo para a pasta main criada em [Instalação fluig]/appserver/modules/com/oracle/oci;

4. Editar o arquivo module.xml de dentro da pasta criada com a tag <module xmlns="urn:jboss:module:1.0" name="com.oracle.oci"> e <resource-root path="ojdbc6_g.jar"/>;

5. Dentro da pasta main criada, deverão estar os arquivos module.xml e 'ojdbc6_g.jar', os demais podem ser excluídos.

Observações
Para que esta configuração funcione é necessário que o client Oracle da máquina esteja configurado corretamente. O client Oracle instalado precisa ser 64 bits.

Saiba Mais
Confira a documentação técnica de Configuração do banco de dados Oracle para mais detalhes sobre as configurações de banco de dados. 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _