Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - CON - Mensagem "Muitos arquivos abertos" ou "Too many open files" ao acessar a plataforma

Ocorrência
Ao tentar autenticar-se na plataforma, está ocorrendo o erro Too many open files ou Muitos arquivos abertos. Como resolver?

IMG-20190506-WA0007.jpg


Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - Todas as versões | Sistema Operacional: Linux

Causa
No Linux, o limite padrão de algumas distribuições é de 1024 arquivos abertos. Porém, muitas vezes pode ultrapassar esse limite devido ao processamento paralelo realizado durante o uso do servidor de aplicação.

Os arquivos abertos são a quantidade de descritores para um recurso alocado para um processo. Os recursos alocados podem ser arquivos no sistema operacional ou outros recursos como, por exemplo, conexões de rede.

No caso da plataforma, temos arquivos temporários, conexões aos clientes que fizeram a requisição (navegador), conexões de rede para os serviços dos quais depende (banco de dados, LDAP, consultas a serviços externos), arquivos do volume e outros recursos sob controle da JVM, como arquivos JAR carregados no classpath e utilizados nos classloaders.

Esse número não é limitado e pode variar, por isso deve ser ajustado o limite máximo se estiver passando do valor configurado atualmente.

Solução
Para aumentar o limite de arquivos execute o comando abaixo:

echo "fs.file-max=65536" >> /etc/sysctl.conf sysctl -p

Saiba Mais
Para saber mais, acesse a documentação sobre Configurações sugeridas em ambientes Linux.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _