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Fluig - Plataforma - BPM - Por que a imagem do diagrama do processo não foi atualizada ao exportar uma nova versão

Ocorrência
Exportamos uma nova versão do processo mas a imagem do diagrama não foi atualizada. Verificamos que a solicitação está seguindo o novo fluxo, somente a imagem ficou desatualizada.
Imagem do diagrama exibida na inicialização de uma nova solicitação:

 

 

Imagem do diagrama exibida no editor de processos:

 

Ambiente
fluig - Processos - Todas as versões.

Causa
Este problema ocorreu devido ao lock de arquivos na workspace utilizada.
Quando é feita a exportação de um processo para o fluig, são criados alguns arquivos na pasta .resources no diretório [workspace] \ [projeto] \ workflow.
A cada nova exportação, o plugin do fluig recria estes arquivos para enviá-los atualizados ao servidor. Já tivemos relatos de problemas onde ocorreu bloqueio dos arquivos (lock) pelo próprio sistema operacional ou aplicações terceiras, não permitindo a atualização. Assim, o arquivo desatualizado é enviado ao servidor fluig, gerando inconsistências semelhantes à esta que foi reportada acima.

Solução
Para solucionar esta inconsistência, acesse a pasta .resources e busque por todos os arquivos (.xml, .png, .svg, etc.) cujo o nome seja o código do processo e faça a remoção.
Por fim, faça uma nova exportação do processo e verifique se o problema foi solucionado.

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