Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - CON - Erro de conexão com o banco SQL Server ao iniciar a plataforma

Ocorrência
A plataforma não está iniciando. No arquivo de log aparece um dos erros abaixo:

  • Connection refused: connect. Verify the connection properties
Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: The TCP/IP connection to the host localhost, port 1433 has failed. Error: "Connection refused: connect. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.".
  • The password of the account must be changed
Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: Login failed for user 'fluig'. Reason: The password of the account must be changed.

Por que isso ocorre? Como resolver?

Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - A partir da versão 1.6.0 | Banco de dados: SQL Server

Causa
Na instalação da plataforma, são informados os dados de conexão com o banco, como instruído na documentação Configuração do Banco de Dados SQL Server.
Ao iniciar os serviços, a plataforma tenta fazer a conexão com o banco, utilizando os dados fornecidos na instalação. Se estiver tudo certo, a plataforma vai popular a base pela primeira vez e permitir o acesso. Porém, caso alguma informação não tenha sido definida corretamente, a plataforma não inicia.

Essa mensagem no log, é um retorno do próprio SQL Server, informando que a plataforma não conseguiu se conectar com o banco e que você precisa verificar as propriedades de conexão. 

Solução
Verifique no arquivo domain.xml (localizado em: [diretório_instalação]\appserver\domain\configuration) se foi realizada alguma configuração incorreta durante a instalação, tal como: porta, instância, nome do usuário, senha, etc.

Nesse arquivo, procure por:

  • java:/jdbc/FluigDS 
  • java:/jdbc/FluigDSRO
  • java:/jdbc/AppDS

Esses blocos (datasources) possuem campos de configuração do banco e podem ser alterados. Após realizar as alterações, você deve salvá-las e iniciar os serviços do Fluig novamente.

Importante
Por questões de segurança é altamente recomendável efetuar a Encriptação de senha do banco de dados.

Saiba Mais

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _