Ocorrência
O serviço fluig não está sendo finalizado com sucesso. Após tentar parar o serviço, o status fica Parando ou Stopping e assim o serviço fica travado.
Os demais serviços (Indexer e Realtime) funcionam corretamente.
O que pode estar causando isso? Como resolver?
Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - Todas as versões
Causa
O motivo do serviço fluig não ser devidamente encerrado pode variar de cenário para cenário. O fato é que esse não é um comportamento do fluig em si, pois geralmente está associado com uma interferência externa, seja de outra aplicação, servidor, etc.
O cenário mais comum é o de possuir aplicação de backup rodando nas pasta e no mesmo servidor da plataforma, de forma que ele não consiga fazer os procedimentos necessários para parar.
Outro motivo bem comum é possuir um antivírus ativado, sem ter o fluig como exceção, ou estando ativado no mesmo servidor. Isso pode impedir, assim como aplicações de backup, a plataforma de apagar pastas temporárias, que é um procedimento padrão em seu desligamento.
Solução
A recomendação é que exista um servidor dedicado à plataforma, sem que tenha esses outros recursos juntos. Recomendamos que seja feita uma análise voltada para o seu cenário. Caso seu servidor tenha essas características, faça um teste desativando as aplicações, para avaliar se ainda há uma interferência com o serviço do fluig.
Saiba Mais
Caso desejado, revise nossas recomendações no Guia de instalação.
0 Comentários