Ocorrência
Estão ocorrendo problemas na visualização de documentos através do Fluig Viewer. Mensagem no log:
ERROR [com.totvs.technology.ecm.viewer.DocumentViewerUrlServlet] (default task-29) Connection failed and the session will be stopped: Connection refused: connect: java.net.ConnectException: Connection refused: connect
O que pode estar causando esse problema? Como resolver?
Ambiente
TOTVS Fluig Plataforma - Documentos - A partir da versão 1.6
Causa
Esse erro pode ocorrer por restrições de Firewall e problemas com o parâmetro no cadastro da empresa.
Solução
Verifique os itens abaixo:
1. O servidor onde está instalado o TOTVS Fluig Plataforma deve ter acesso externo liberado, pois o visualizador deve acessar a URL https://api.accusoft.com.br. Devem ser feitos os devidos ajustes de rede para que seja possível que a plataforma acesse esse endereço.
2. Em casos onde existe um DNS na plataforma, recomendamos que a configuração seja feita seguindo a documentação Considerações de DNS para a plataforma. Também é necessário configurar o proxy reverso de acordo com a documentação Configuração de Proxy Reverso.
3. Acesse a plataforma com o usuário wcmadmin, acesse o Painel de Controle, localize o agrupador WCM e acione a opção Empresas. Edite o cadastro da empresa desejada, acionando a opção Cadastrar dados adicionais e efetuando as ações abaixo:
- Procure pelo parâmetro internalVisualizerServer.
- Se ele existir, remova-o e cadastre-o novamente informando https://api.accusoft.com.br no campo Valor.
- Se ele não existir, cadastre-o com o valor citado.
- Procure pelo parâmetro oldViewer.
- Se ele não existir não é necessário cadastrá-lo.
- Se ele existir, remova-o.
- Salve as alterações na tela Dados adicionais.
- Salve as alterações na tela de cadastro da empresa.
4. Certifique-se também que as URL e portas 443 e 80 estejam liberadas no servidor.
Saiba Mais
Para mais detalhes acesse a documentação de Configuração do Fluig Viewer.
0 Comentários