Tempo aproximado para leitura: 00:06:00 min
Ocorrência
Estamos tentando realizar impressão de cópia controlada, contudo não está gerando o documento. O erro apresentado é de que não foi possível carregar o Applet.
Por que isso ocorre? Como resolver?
Ambiente
TOTVS Fluig Plataforma - Documentos - Todas as versões
Causa
A impressão de cópia controlada foi desenvolvida inicialmente com o recurso de applets, porém este recurso atualmente está disponível somente para o navegador Internet Explorer. Os navegadores Google Chrome (versão 45 ou superior) e Mozilla Firefox (versão 52 ou superior) não suportam mais a execução dos plugins NPAPI necessários.
Este recurso possibilita identificar qual impressora foi selecionada e também definir o número de cópias emitidas.
Caso você deseje utilizar essas opções é necessário atender os requisitos a seguir:
- Configurar o Ambiente de execução do Java® no computador do usuário que fará a impressão;
- Utilizar o navegador Internet Explorer. Acesse a Matriz de Portabilidade para saber qual é a versão homologada;
-
Marcar a opção "Habilita applet" em Painel de Controle > Parâmetros. Para saber mais sobre essa tela acesse a documentação sobre Parâmetros.
Quando a opção "Habilita applet" está marcada no Painel de Controle > Parâmetros, você NÃO conseguirá fazer a impressão através dos navegadores Firefox ou Chrome. Ao tentar fazer isso, será apresentada a mensagem "Não foi possível carregar applet".
Nesse caso, você poderá apenas fazer a impressão através do Internet Explorer.
Se quiser fazer a impressão através dos outros navegadores, desabilite a opção. Lembrando que nesse caso, a informação de qual impressora foi selecionada, não será registrada.
Agora, se você utiliza o Internet Explorer e a mensagem ainda é exibida pode ser que o Java não esteja habilitado em seu navegador.
Solução
Recomendamos que seja reinstalada a aplicação do Java, só que diretamente do Internet Explorer, para que ele venha habilitado no navegador e seja possível utilizar os recursos.
Para confirmar, abra o painel de controle do Java, na aba Avançado, e procure pelo trecho Java Padrão para browsers. A opção do Microsoft Internet Explorer deve estar selecionada, conforme a imagem a seguir:
Caso verifique isso e consiga resolver a situação, já adiantando, pode ser que haja um novo ponto a ser avaliado, que é a configuração do Open Office. Para isso, acesse a plataforma com o usuário wcmadmin e navegue até Painel de Controle -> Configurações do Sistema.
Na aba Parâmetros da plataforma acesse a área Configurações do OpenOffice e marque como ON o campo Habilitar OpenOffice. Após essa revisão, reinicie os serviços do fluig.
Por último, tente imprimir novamente, seguindo as configurações dos itens Impressão de documentos, Acionar a impressão e Realizar a impressão da documentação de Impressão de cópia controlada.
0 Comentários