Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - CON - Validações de configuração em banco de dados

Ocorrência
A plataforma não está iniciando. No arquivo de log é apresentada a mensagem abaixo:

FATAL [com.fluig.startup.validation] (Thread-90) ===================================================================
FATAL [com.fluig.startup.validation] (Thread-90) == Alterar o collation da base                                  
FATAL [com.fluig.startup.validation] (Thread-90) == Collation correto Latin1_General_CI_AS                   
FATAL [com.fluig.startup.validation] (Thread-90) ===================================================================

ou então:

[Server:fluig1] 09:11:46,438 FATAL [com.fluig.startup.validation] (Thread-100) == Alterar o charset da base 
[Server:fluig1] 09:11:46,438 FATAL [com.fluig.startup.validation] (Thread-100) == Charset correto AL32UTF8

Obs: o arquivo de log pode ser acessado em [diretório_instalação]\appserver\domain\servers\fluig1\log\server.log.

Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - A partir da atualização Essential 1.6.5-190702.

Causa
A partir da atualização Essential 1.6.5-190702 a plataforma passou a fazer uma validação de charset e collate do banco de dados antes da inicialização, para verificar se as configurações estão corretas. Caso seja identificada alguma divergência, o processo de inicialização será interrompido.

Solução
Para inicializar a plataforma, você precisará ajustar a codificação do banco de dados. Recomendamos que sejam revisadas as configurações de acordo com a documentação de configuração do seu banco de dados. Acione um especialista em banco de dados para realizar essa operação caso não tenha conhecimento.

Utilize um ambiente de homologação para fazer a alteração e os testes antes de aplicar as configurações em produção. Para saber como criar um ambiente de homologação, acesse: Criando um ambiente de homologação.
_________________________________________________________________________________________________

Atenção!
Não nos responsabilizamos por problemas que possam vir a acontecer na utilização da plataforma que envolva atualização de charset na base de dados e nas tabelas, enquanto o correto ajuste do charset do banco não for realizado!

Caso essa alteração não for realizada, a plataforma estará executando com risco de mal funcionamento, por exemplo, com relação à acentuação e uso de caracteres especiais.

O fornecedor do banco de dados possui documentações que podem guiar o processo de conversão de charset.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _