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Fluig - Identity - SSO - Mensagem de que o certificado SAML do contexto está prestes a expirar

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Ocorrência
Ao acessar o Identity, recebi um alerta informando que o certificado SAML do meu contexto está prestes a expirar. O que preciso fazer?

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Ambiente
TOTVS Identity - Desktop SSO - Todas as versões

Causa
A duração atual do certificado é de 10 anos a partir da data de criação do contexto. Ao final desse período, é necessário renová-lo e atualizá-lo nas aplicações SSO.


Solução
A renovação do Certificado SAML e do Certificado SAML RSA 2048 ocorrem em duas etapas: renovar o certificado por um novo período no próprio contexto do Identity, e depois atualizar o certificado nas aplicações SSO.

1. Renovar certificado no Identity:

  • Acesse o contexto com um usuário administrador.
  • Acesse as configurações  e selecione a opção Segurança
  • Na seção Certificado SAML, acione a opção Renovar Certificado.
  • Assinalar Li e concordo com a renovação do certificado.
  • Acionar Renovar.

Importante: Para renovar o Certificado SAML RSA 2048 siga os mesmos passos acima mencionados.

 

2. Atualizar certificado nas aplicações SSO: 

  • TOTVS Fluig Plataforma: basta acessar com o usuário wcmadmin, editar a empresa que está integrada ao Identity, na aba Autenticação testar a conexão e salvar sem alterar nada. O certificado atualizado será baixado automaticamente.
  • GoodData: acessar o Portal do cliente e abrir um ticket solicitando a atualização do certificado na GoodData e informando a URL do contexto da empresa no Identity (Ex.: http://minhaempresa.fluigidentity.com).
  • ERPs TOTVS: basta refazer a integração nas configurações da aplicação. Cada ERP possui uma documentação detalhando esse procedimento: Linha Protheus, Linha RM, Linha Datasul e Linha Logix.
  • Zendesk: Volte ao contexto do Identity, acesse as configurações  e selecione a opção Segurança. Na seção Certificado SAML, acione a opção Download do certificado. Abra o certificado SAML baixado, acesse a aba Detalhes, localize Impressão Digital na lista de campos apresentada e copie o valor da impressão digital do certificado. Após isso acesse o Zendesk da empresa com o administrador. Selecione Admin > Configurações > Segurança. Localize as configurações de SAML na seção Single Sign-on (SSO), cole o valor no campo Impressão digital do certificado* e acione Salvar.

 Saiba Mais

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