Ocorrência
Ao tentar acessar a plataforma a partir do Identity com um usuário específico, a seguinte mensagem de erro é apresentada: Usuário não tem permissão para acessar o sistema ou User does not have permission to access the system.
Por que isso ocorre? Como resolver?
Ambiente
TOTVS Fluig Plataforma - Usuários - A partir da versão 1.6.5
Causa
Essa mensagem pode ser apresentada por diversos motivos, por isso listamos neste artigo as causas mais comuns e suas respectivas soluções.
Solução
Efetue as verificações abaixo:
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Não há mais licenças disponíveis na plataforma, por isso o usuário não foi criado: Acesse License Server Monitor e verifique o número total de licenças adquiridas para o TOTVS Fluig Plataforma. Em seguida, acesse o recurso Usuários, no Painel de Controle da plataforma, e verifique a quantidade de usuários ativos, que contam licenças. Caso tenha sido alcançado o número total, será necessário adquirir mais licenças ou desativar outro usuário para liberar uma licença.
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O usuário foi desativado na plataforma: Reativar o usuário, acessando a plataforma e acionando Painel de controle > Usuários.
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O parâmetro Just in time não está habilitado na configuração de integração da plataforma com o Identity do painel de controle do wcmadmin: Habilitar o parâmetro Just in time para que os usuários sejam provisionados automaticamente ao acessar a plataforma pela primeira vez. Para saber mais acesse essa documentação.
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O ID do usuário (idp_id) está vinculado à conta de outro usuário na plataforma: Abrir um ticket para o Suporte TOTVS Fluig.
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Mensagem de erro no arquivo server.log: Reiniciar o Fluig.
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O e-mail do usuário foi alterado no Active Directory:
Remover o usuário do aplicativo e adicioná-lo novamente. Acessar o cadastro do usuário no Identity, acionar Gerenciar (Aplicativos Atribuídos), localizar o aplicativo Fluig e acionar Definir login SAML. Ajustar o e-mail do usuário e salvar.
Dica! Para evitar que isso ocorra, habilitar a opção Sincronizar login SAML com e-mail do AD na aba Editar das configurações do aplicativo para que o e-mail do usuário seja atualizado automaticamente após a alteração no AD.
Observações
Caso o problema afete todos os usuários, a porta 443 usada na comunicação entre a plataforma e o Identity pode ter sido bloqueada. Para verificar, acessar o Painel de controle do wcmadmin e na configuração de integração com o Identity acionar Ações → Testar conexão.
Caso o teste não seja bem sucedido, o administrador da rede deve verificar a disponibilidade da porta.
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