Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - CON - Mensagem no log na inicialização da plataforma

Ocorrência
Em algumas situações, a plataforma não está iniciando corretamente, gerando uma mensagem de erro conforme exemplo a seguir. Como resolver?
 
log.png

Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - A partir da versão 1.7 (Lake)


Causa
As novas instalações da 1.7 estão vindo com o parâmetro keepalive-time do pool de threads com 60 segundos, mas as instalações que são atualizadas da 1.6.4, continuam com o valor padrão da versão antiga, que é 100 milissegundos:

<thread-pool name="default">
<max-threads count="10"/>
<keepalive-time time="100" unit="miliseconds"/>
</thread-pool>

Percebemos que, quando este parâmetro está com um valor muito baixo, pode impedir a correta inicialização da plataforma.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

01. Edite o arquivo domain.xml (localizado em: [diretório_instalação]/appserver/domain/configuration/)
02. Pesquise pelo parâmetro keepalive-time. Altere a propriedade time para 60 e unit para seconds.
03.
Salve e inicie os serviços.

Confira como fica a parametrização correta para a atualização 1.7:

<thread-pool name="default">
<max-threads count="10"/>
<keepalive-time time="60" unit="seconds"/>
</thread-pool>
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _