Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - DES - Por que ocorre o erro java.lang.ClassNotFoundException ao consultar o dataset?

Ocorrência
Por que ocorre erro java.lang.ClassNotFoundException ao executar o dataset?

Exemplo no log:

2020-11-09 17:17:12,443 INFO  [com.datasul.technology.webdesk.customization.ScriptingLog] (default task-11) #### @ds_generic_rm_sql diz: Erro ao executar o dataset DsGeneric: java.lang.ClassNotFoundException: br.com.totvs.WsConsultaSQL

 

Ambiente
TOTVS Fluig Plataforma - Desenvolvimentos - Todas as versões

Causa
Este incidente ocorre por que foi chamado uma classe no desenvolvimento que o sistema não encontrou no serviço. O endereço do serviço precisa ser o mesmo do desenvolvimento, caso houver uma classe da qual foi informado um pacote e estiver diferente da chamada no desenvolvimento o erro será apresentado.

Exemplo de um cadastro incorreto onde o erro é apresentado:

Dataset:

mceclip0.png

Classe:

mceclip2.png

 

Solução
Verifique a nomenclatura da classe no Fluig e se foi informado o pacote corretamente.

Exemplo de um cadastro correto:

Dataset:

mceclip3.png

Classe:

mceclip4.png

Segue passo a passo realizado para ajustar:

No Eclipse > Editar serviço > Informe o serviço a ser editado

mceclip7.png

Informar o pacote e clicar em Finish:

mceclip6.png

Após esse ajuste o Dataset deve ser consultado com êxito.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _