Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - BPM - Mensagem "Row size too large" ao exportar ou movimentar formulário

Ocorrência

Ao tentar exportar um novo formulário para a plataforma ou movimentar uma solicitação, são apresentados erros da seguintes formas:

com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Row size too large. The maximum row size for the used table type, not counting BLOBs, is 8126. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs
ERROR [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] (default task-25) Row size too large (> 8126). Changing some columns to TEXT or BLOB or using ROW_FORMAT=DYNAMIC or ROW_FORMAT=COMPRESSED may help. In current row format, BLOB prefix of 768 bytes is stored inline.
 
Por que isso ocorre?

Ambiente
TOTVS Fluig Plataforma - Processos - Todas as versões

Causa
Esta situação ocorre em dois cenários, sendo o primeiro na exportação de formulário devido a quantidade de campos contidos no mesmo, com isto, o banco restringe a criação da tabela do formulário (metalista). O segundo cenário trata-se da movimentação de solicitações, onde o número de caracteres informados ultrapassa o limite do banco e acaba por restringir o envio das informações.

Solução

Há uma medida de contorno, a qual poderá ser adotada, mas não é assegurado em todos os casos que a mesma solucionará o incidente, cabe ressaltar que essa limitação é do próprio banco de dados e não uma limitação do produto.

A medida consiste em alterar os parâmetros de limitações do MySQL. Para realizar o procedimento, basta inserir (ou alterar) as seguintes chaves no arquivo my.ini (em Windows) ou my.cnf (em Linux):

innodb_log_file_size=8G
innodb_log_buffer_size=800M
innodb_buffer_pool_size=800M
innodb_strict_mode=0
 

Em seguida, é necessário reiniciar o serviço do banco de dados para que as alterações entrem em vigor.

 

Observação

Caso o incidente persista após a alteração dos parâmetros, recomendamos que seja implementando em seu diagrama o uso de um Subprocesso, visando dividir o formulário, seja para sanar a questão do número de campos inseridos no mesmo ou o número de informações a serem enviadas durante a movimentação de uma solicitação.

 

IMPORTANTE:

Clientes cloud precisam entrar em contato com o time de Cloud solicitando a alteração dos parâmetros de limitações do MySQL. Para realizar o procedimento, a equipe cloud precisa inserir (ou alterar) algumas chaves no arquivo my.ini (em Windows) ou my.cnf (em Linux). Em seguida, é necessário reiniciar o serviço do banco de dados para que as alterações entrem em vigor.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _