Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - BPM - Dataset da definição de formulário não retorna informações

Tempo aproximado para leitura: 00:01:00 min

Ocorrência

Após movimentar a solicitação e preencher os dados no formulário, não está sendo possível consultar o dataset da definição do formulário. A consulta não retorna informações:

image2015-10-7_15_28_50.png


Ambiente
TOTVS Fluig Plataforma - Processos - Todas as versões


Causa

O problema aconteceu porque o formulário utilizado não possuí campos no form principal. Todos os inputs estão dentro do tablename, ou seja, são registros do formulário pai e filho.

Por este motivo, ao realizar a consulta do dataset do formulário, nenhuma informação é retornada. 


Solução

Para retornar as informações do formulário pai-filho, será preciso criar um dataset customizado. Abaixo segue uma documentação que explica e exemplifica como poderá ser feita a consulta:

3.4 Dataset customizado de definição de formulário "pai-filho" Construção do Dataset Avançado.

É necessário criar pelo menos um campo no formulário principal para retornar informações no dataset. Este campo pode ser do tipo hidden e pode estar vazio, entretanto, precisa existir no formulário.

 

Observação

Na versão 1.5.2 do fluig não é possível exportar formulários sem que exista pelo menos um campo no formulário principal.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _