Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - WCM - Erro 403 Forbiden é exibido ao consultar API Fluig em widgets de páginas públicas


Tempo aproximado para leitura: 00:01:08 min

Ocorrência

Ocorre o erro "403 forbidden" ao consultar API REST do Fluig em widgets de páginas públicas, ou seja, sem usuário autenticado.

Ambiente
TOTVS Fluig Plataforma - Configurações Técnicas - Versão 1.7.0 Lake e superior. 


Causa
Ao fazer uma requisição REST é necessário passar a URL completa do servidor no parâmetro URL da requisição.

Solução
Concatenar a URL do servidor com a URL da API REST que deseja consumir.

var url = WCMAPI.getServerURL();
var request_data = {
url: url+'/api/public/ecm/dataset/datasets',
method: 'POST',
ajaxData: JSON.stringify(
{ name : "ds_teste",
fields : [],
constraints : [{
_field : "metadata#active",
_initialValue: "true",
_finalValue : "true",
_type: 0,
_likeSearch: false
}],
order : []}),
data: {}
};
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _