Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - WCM - Como resolver quando todos os widgets tem a mesma preferência


Tempo aproximado para leitura: 00:03:43 min

Ocorrência

Como resolver quando todos os meus widgets estão com as mesmas preferências?

Ambiente
TOTVS Fluig Plataforma - Widgets - Versão 1.7.0 Lake e superior.


Causa
Geralmente isso ocorre quando há mais de um elemento com o mesmo "id" na página. O risco de isso ocorrer é maior quando, montando uma pagina, use-se mais de uma instância de um widget que não esteja com os "ids" de seus elementos nomeados corretamente.

 

Saiba mais!

O conceito de instância está geralmente ligado a um widget. Cada vez que um widget é adicionado em uma página, ele é considerado uma "Instância de Widget". Cada instância de widget possui um código único dentro da plataforma e isso permite que, por exemplo, duas instâncias do widget de endereço externo mostrem sites diferentes.

Solução
Dentro dos arquivos .ftl, sempre que é criado um novo elemento, é importante utilizar a variável instanceId como sufixo na hora de nomeá-lo. Abaixo um exemplo:

<div id="TesteQualidade_${instanceId}">
<form role="form">
<div id="formForm_${instanceId}">
<div class="form-group">
<label for="qualiTitle_${instanceId}">...</label>
<input type="text" class="form-control" id="qualiTitle_${instanceId}" value="${qualiTitleDataField!}"/>
</div>
</div>
</form>
</div>

Onde:

Elemento Descrição
${instanceId} Quando utilizada a técnica de super widget, essa variável contém o "id" único da instância em questão.

 

Usar instanceId como sufixo é bastante produtivo quando é necessário fazer referência a outros objetos dentro do próprio .ftl, pois quando foi inserida a label para o input, bastou usar como referência o identificador único do objeto em questão. Ou seja, quando o input field foi criado, deu-se um "id" único para ele.

<input type="text" class="form-control" id="qualiTitle_${instanceId}" value="${qualiTitleDataField!}"/>

 

Logo, quando a label para ele foi criada, bastou informar na propriedade "for" o mesmo valor.

<label for="qualiTitle_${instanceId}">

 

Essa forma de nomear seus elementos também ajudará quando for necessário, dentro do arquivo .js, buscar algum valor na tela. Abaixo um exemplo:

var titulo = $("#qualiTitle_" + this.instanceId).val();

 

Onde:

Elemento Descrição
$(...) Função que inicia a buscar por algum elemento na tela.
# É o prefixo que indica, para o javascript, que se deseja buscar um elemento cuja propriedade "id" seja igual aos caracteres que se seguem a ele.
this.instanceId Quando utilizada a técnica de super widget, essa variável contém o id único da instância em questão.

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _