Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - BPM - Throw não funciona no evento de processo AfterProcessFinish

Tempo aproximado para leitura: 00:01:00 min

Ocorrência

Throw não funciona no evento de processo AfterProcessFinish.

Ambiente
TOTVS Fluig Plataforma - Processos - Todas as versões

 

Causa

Existem alguns eventos de processos que não permitem a execução throw, isto ocorre devido ao tempo de execução do próprio evento.

No caso, o afterProcessFinish é disparado logo que uma solicitação é finalizada, desta maneira, a execução do throw não é válida.

Apenas para conhecimento, comumente o throw é utilizado para apresentar mensagens de validação aos usuários, impedindo que o avanço do processo até que a condição especificada seja satisfeita. No caso, o afterProcessFinish é executado depois de que a solicitação é encerrada, ou seja, não seria possível e até mesmo coerente lançar uma exceção após o processo ter sido finalizado.


Solução
A documentação oficial para desenvolvimento de workflow destaca que o tratamento de exceções pode ser utilizado apenas nos eventos: beforeStateEntry, beforeTaskSave e beforeCancelProcess. Veja a documentação abaixo:

Desenvolvimento de Workflow

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _